Don't allow database update if java doesn't support JCE unlimited strength jurisdiction policy files

Description

If a host is running an older version of Java 8 that is missing the Java Cryptography Extension (JCE) Unlimited Strength Jurisdiction Policy Files, the migration for fails with:

This should only apply to java 8 versions prior to update 161: https://www.oracle.com/technetwork/java/javase/8u161-relnotes-4021379.html#JDK-8170157

Also see https://stackoverflow.com/questions/42159690/why-are-the-jce-unlimited-strength-not-included-by-default

Environment

None

Assignee

Tim Anderson

Reporter

Tim Anderson

Labels

None

Components

Fix versions

Priority

Minor
Configure